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Abstract- The application of Engineering software’s with the integration of today’s industrialization is 

becoming broad and plays important role in many facilities. Different construction firms and enterprises have 

shifted their approach and have started using them for analysis and design of structures. In place of wrong 

software adaptation habit of one Engineering firms from another, the software features have to be thoroughly 

investigated to prefer one software over another for a specific task. This paper mainly focuses upon the 

comparison of SAP2000 and STAAD Pro to make structural engineering tasks more simple and efficient method 

of analyzing and design of structural members. In this paper comparison of SAP2000 and STAAD Pro results 

has been presented by designing sample beams and frames as per IS 456. The results of investigation is also 

presented according to their respective features.  
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I. Introduction 
There is no question that the use of software has simplified the analysis and design procedures of 

structures. But using software requires an earnest understanding of engineering concepts behind the software 

functionality. One has to fully understand the basic assumptions and considerations made when the software 

was originally developed. Lacking the required knowledge of the basic engineering principles can easily lead to 

devastating results. When using commercial engineering software we have to study in depth the merits and 

demerits of one software over the other. Though they usually own similar character in basic principles, the 

comparison processes needs a very close look at the full application and utilization of each software with its 

limitations. Commercial software are becoming more and more competitive by highly upgrading their features 

on every new version. So a careful examination of their features is necessary for comparing software 

functionality in different aspects. 

The SAP2000 (Structural Analysis Program) name has been synonymous with state-of-the-art 

analytical methods since its introduction over 40 years ago [23]. Founded in 1975 by company President Ashraf 

Habibullah, CSI (Computers & Structures Inc.) is recognized worldwide in the development of software tools 

for the analysis and design of civil structures. CSI products are licensed to thousands of structural engineering 

firms in more than 100 other countries [23]. The development of CSI software spans four decades, starting with 

the research of Dr. Edward L. Wilson at the University of California at Berkeley. The revolutionary SAP 

program was first released in 1970, and Dr. Wilson has subsequently been recognized by national and 

international engineering societies as one of the preeminent researchers in the field of computer aided structural 

analysis. Each of CSI's programs is tailored to specific classes of structures, allowing the engineering 

community to work at efficient levels that are possible with "general purpose" type programs. SAPis intended 

for use on civil structures such as bridges, dams, stadiums, industrial structures and buildings. ETABS has been 

developed specifically for multi-story building structures, such as office buildings, apartments and hospitals. 

The SAFE System provides analysis and design of concrete slabs and foundations. 

SAP features user interface powered by analysis engine and design tools for engineers working on 

transportation, industrial, public works, sports, and other facilities. 3D object based graphical modeling 

environment to the wide variety of analysis and design options are completely integrated across one powerful 

user interface. This intuitive interface allows creating complex structural models that can be generated and 

meshed with templates built into the interface. 

STAAD.Pro is a general purpose program for performing the analysis and design of a wide variety of 

types of structures. The basic three activities which are to be carried out to achieve that goal - a) model 

generation b) the calculations to obtain the analytical results c) result verification - are all facilitated by tools 
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contained in the program's graphical environment. STAAD.Pro was developed by practicing engineers for 

practicing engineers around the globe. It has evolved over 28 years and is constantly guided by a premier 

industry-based steering committee [22]. The company claims that STAAD.Pro is the choice of 47 out of 50 

leading Structural Engineering firms, 46 out of 50 state Dots and 7 out of the top 10 engineering universities 

[22]. STAAD.Pro features a user interface, visualization tools, analysis and design engines with advanced finite 

element and dynamic analysis capabilities. 

Currently, the program support over 70 international codes and approximately 20 US codes [22]. 

Unlike most structural software, STAAD.Pro can be customized by the user to exactly fit design needs. 

STAAD.Pro is developed on an open architecture called Open STAAD. All of the functions related to input or 

output are available to the user, such as Get Maximum Bending Moment or Add Uniform Load. STAAD also 

include a parametric library of pre-built commonly used structures like trusses, buildings, mats, etc. that can be 

customized by for modeling repetitive structures. The user can even add a template. In addition, STAAD.Pro 

has an embedded VBA (Visual Basic for Applications) editor which enables users to write their own design, 

loading, or post-processing routines directly in the STAAD environment. 

 

II. Comparison Critera 
2.1.Modeling 

 Modeling a structure using software highly depends on the engineering assumptions considered. 

Generating models is the most important step in the analysis and design procedure of any structure. The required 

engineering concepts and parameters are mostly applied at this stage. Once the structural model is properly 

created the analysis and design procedures are simply computational processes. Therefore high level of care 

should be taken as to how precisely we model our structure. 

 In STAAD.Pro there are two methods for building a model and assigning the structure data which are 

using the command files and using the graphical model generation mode or graphical user interface (GUI). 

 In SAP2000 the model template form allows for the quick generation of numerous model types using 

parametric generation techniques. The model can be started using the grid generation. When laying out the grid, 

it is important that the geometry defined, accurately represents the major geometrical aspects of the structure. 

The model features of both software are comparatively tabulated as follows. 

 

Table 2.1: Modeling feature analysis of SAP2000 and STAAD.Pro 
No

. 

Features SAP20

00 

STAAD.P

ro 

1 Parametric mesh model     

2 Roaming grid labeling for construction lines 

for easy beam/column placement.  

   

3 Selective labeling to turn on/off individual 
beam/plate/solid labels with new shortcut 

keys 

   

4 Unlimited Undo and Redo    

5 More structure wizard models including user-
defined parametric structures to create any 

structural template 

   

6 Generate, copy, repeat, mirror, pivot, for 
quick and easy geometry generation 

    

7 Import AutoCAD DXF files     

8 Access to text editor    

9 User-controlled scale factors for deflected or 

mode shapes 

   

10 Structure Wizard to create meshes with holes 

and curved surfaces 

   

11 Auto-meshing of complex slab systems. 

Automatically refines the mesh if columns or 
openings or wall lines are added 

   

12 Dynamic auto-scaling of all force diagrams 

while zooming 

   

13 Area (Shell) and Solid Objects with Internal 
Meshing 

   

14 Integrated Graphical Section Designer for 

Complex Frame Shapes 

   

15 Accurate Dimensioning with Guidelines and 
Snapping 

   

16 Auto Edge Constraints for Mismatched Shell 

Meshes 

   

17 Quick Draw Options for Object Creation    

18 Definition of Highway Layout Lines    

19 Automatic Generation of Code Lateral Wind    
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and Seismic Loads 

20 Wind Loads on Open Structures    

21 Transfer of Loads from Area Objects to 

Framing Systems 

   

22 Bridge Wizard for Bridge Modeling     

23 User-defined axis of rotation for viewing     

24 Fireproofing on columns, beams and braces     

25 Generate, copy, repeat, mirror, pivot, for 

quick and easy geometry generation 

    

 

2.2 Analysis 

 Before designing a given structure, a civil engineer have to be able to determine the stresses (external 

and internal) being imposed on the structure. In order to do this, structural analysis procedure is required. It is 

very important to know the engineering methods used by the software for analysis. A deep knowledge in the 

analysis method being applied is very useful as to determine the reliability of the result and the limitations of the 

analysis methods for a given model. The analysis features in both software, SAP2000 and STAAD.Pro, are 

comparatively tabulated below. 

 

Table 2.2: Analysis feature comparison of SAP2000 and STAAD.Pro 
No

. 

Features SAP20

00 

STAA

D.Pro 

1 Staged construction (construction 
sequence loading), including multiple 

scenarios 

   

2 For the special case of pushover analysis 
including effective damping 

computations, capacity spectrum 

computations and demand spectrum 
comparisons are also performed 

   

3 Large displacement analysis    

4 Eigen analysis with an accelerated 

subspace iteration algorithm 

   

5 Ritz analysis for optimal mode 
superposition basis 

   

6 Modal analysis including P-delta, large 

displacement and construction effects 

   

7 Load forcing functions    

8 Transient or steady state    

9 Provides correspondence between 

response components 

   

10 Create and run new cases while keeping 
results already calculated 

   

11 Tapered tubular cross-sections such as 

hexagonal, octagonal, etc. 

   

12 Plate elements contain extra “drilling” 
degree of freedom 

   

13 Master/slave capabilities    

14 I-beam warping end restraint added as an 

option for torsional stiffness 

   

15 Automatic spring support generator for 

mat foundations 

   

16 Active/Inactive members for load-

dependent structures 

   

17 Determine stresses and forces along any 

cut line through a group of plates by 

cutting with a plane 

   

18 Elbows (curved beams with pipe 
sections) can be modeled with an internal 

pressure 

   

19 Modal Damping Ratio for Individual 
Modes 

   

20 Nonlinear frame, cable and link elements     

21 P-Delta analysis     

22 User defined truck, lane and train loads     

23 Determination of maximum and 
minimum displacements and reactions 

    

24 Buckling load analysis     

25 Multiple analysis in same run     

26 Buckling analysis     

27 Member and spring specification     
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28 Compression-only and tension-only 
members, multi-linear (non-linear) 

spring supports 

    

29 Beam, truss, tapered beam, shell/plate 
bending/plane stress and 8-noded solid 

elements 

    

30 Base shear calculation includes direction 

factors 

    

31 Extraction of Frequency and Mode 

Shapes 

    

32 Generate floor spectra from time history     

 

 Both software use the finite element method for analysis. The computational efficiency of both 

packages is more or less parallel. Implying that the computational time for carrying out simple duties is almost 

similar in both cases. But for structures with very large number of members and irregularities, the computational 

procedure takes more time. 

 

2.3 Design 

 The main purpose of the whole procedure revolves around this step. In this step we have to be able to 

suggest a suitable structural section capable of supporting the stresses expected on the member. This can be 

carried out using different design codes depending on the location of the practice and the assumptions made. 

The design features in both software, SAP2000 and STAAD.Pro are critically tabulated as follows. 

 

Table 2.3: Design feature analysis of SAP2000 and STAAD.Pro 
No

. 
Features SAP2

000 
STAAD.

Pro 

1 Aluminum Frame Design    

2 Straight & Curved Girder Design    

3 Virtual Work Based Optimization 
for Lateral Deflections 

   

4 Grouping for Design Envelopes    

5 Automated Effects of Panel-Zone 

Deformations on Lateral Drift 

   

6 API Punching Shear Checks    

7 P/T Concrete Box Girder Design    

8 Design of HSS Section    

9 Design of tapered sections like I-

beams and hexagonal, 
dodecagonal and octagonal tubes 

   

10 Design cold-formed and 

aluminum sections with full 
database library included 

   

11 Welding design code    

12 Transmission tower design code    

13 Design for Beams with Web 

Openings 

   

14 Check for Floor Vibrations due to 

Rhythmic Activities 

   

15 Steel Frame Design for AISC-

ASD & LRFD, AASHTO, API, 
UBC, British, Canadian, Italian, 

Indian and Euro Codes 

    

16 Concrete Frame Design for ACI, 
AASHTO, UBC, British, 

Canadian, New Zealand, Indian, 

Italian, Korean, Mexican and Euro 
Codes 

    

17 Design for Static and Dynamic 

Loads 

    

18 Designed for Biaxial-
Moment/Axial-Load Interaction 

    

19 Seismic Check of Beam/Column 

Joints in Concrete Frames 

    

20 Moment and shear connection 
designer integrated with the steel 

designer to perform several 

column flange-beam moment and 
shear connections 

    

21 Composite beam design (including 

stud spacing) per AISC ASD and 

    
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LRFD 

 

 Both SAP2000 and STAAD.Pro have a list of different design codes they support. STAAD.Pro has 

specific size requirements regarding defining member dimensions, whereas SAP has no boundaries of such 

kind. STAAD.Pro doesn’t carry out design for columns and piers where as SAP2000 does. But the design of 

columns by SAP2000 especially based on the Eurocode often raises questions in result validity. It seems that 

SAP2000 doesn’t fully abide by the column code provisions stated in the Eurocode. 

 

III. Output 
 Both software offer a number of output features for which the user can easily obtain the output result 

for a particular task he/she requires. Both are equipped with animation features which are very useful 

particularly in presentations. Relatively STAAD.Pro grant a more organized and integrated output format. 

STAAD.Pro has a customizable and high quality report available. It can be a summary of pictures exactly as 

seen on screen or complete, fully detailed reports. Extracting data from the model such as the largest node 

displacement at a specific node becomes easy using an inbuilt Advanced Query, SQL tool. On the other hand 

SAP2000 has 3D perspective graphical displays of un-deformed and deformed structural geometry with AVI 

file option for saving animated displays with animated stress contours and multiple windows simultaneously 

displaying different output parameters. The different output features are critically tabulated below. 

 

Table 3: Output feature analysis of SAP2000 and STAAD.Pro 

 
 

IV. Analysis And Design Of Sample Beams And Frames. 
1.1 Analysis and Design using STAAD.Pro 

1. In STAAD.Pro window new project icon is clicked, Provide the file name and location, set the units as KN 

and mm. 

2.  Geometry tab is clicked and the model is prepared using nodes and beams icon. 

3. In General Tab the element thicknesses and material properties is provided. 

4.  The member corresponding to appropriate property is selected, the properties to appropriate members are 

assigned. 

5. Supports tab is clicked and fixed supports to the footings are assigned. 

6. Load & Definition tab is clicked and the load case details are defined i.e. In this case Dead Load, Live 

Load, Roof load and earthquake load. 

7. Loads to members are assigned by selecting members, assigning to view or by simply specifying the ranges. 

8. Load combinations of these loads are generated using auto load combination. 

9. Analysis/ Print tab>No print is added. 
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10. Analysis menu>Run Analysis is clicked. 

11. If the analysis result has no error concrete design of the structure is performed. 

12. Command> Design> Concrete Design. 

13. Commands> add design beam, design column, design slab/element and takeoff is clicked. 

14. In Define Parameters, the minimum cover, Grade of concrete, Grade of steel etc. Is specified. 

15. Design Beam To Beams, Design Columns To Columns, Design Slab/Elements To Slab And Take Off To 

View Is Assigned. 

16. Analysis menu> Run Analysis. 

17. Go to Post Processing Mode radio button and close. 

18. Nodes tab is clicked to view node. 

19. Beams is clicked to view Beam results. 

20. Plates is clicked to view Slab results. 

21. Animation tab is clicked to produce animations corresponding to displacements deflections etc. 

22. Reports tab is clicked to generate reports of the entire structure or a specific element. This also provides 

facility for printing the report. 

23. In the beam tab, a beam or a column is double clicked to view Design results. 

24. The Shear force and Bending moment diagrams for each frame or the entire structure for one loading or all 

the loading at once can be viewed using Shear and Moment toggle button. 

25. In the Plate tab, a slab is double clicked to display the slab output results 

 

4.2 Analysis and Design using SAP2000 

1. In SAP2000 window > New Project> Change units inthe drop down box shown, to KN, m, C. 

2. Define menu> Section Properties> Frame section.  

3. Various parameters are defined in boxes. Here required concrete and steel strength is inserted and have been 

considered. Define>Frame Sections is clicked. Second drop down box of “Choose Property Type to Add” Add 

Rectangular >Add New property Rectangular Section. Section name for Beam is given; parameters in boxes, 

and also Concrete Reinforcement is defined. Similarly same things is done for Columns. To use cracked section, 

Set Modifier is clicked to change stiffness of members to account for cracked section >OK. 

4. Draw button is clicked to draw Frame/Cable/Tendon. Adialogue box will open, click on Section to find 

appropriate section. Draw section on GUI by clicking on nodes. In this problem draw only ground floor beams 

and columns. Note: View can be changed by designer at any time while drawing sections. 

5. After drawing sections again go to drop down menu. Define>Load Case> a dialogue box Define Loads will 

open as shown. It can be observed that a load named Dead is already defined with a self-weight multiplier 1, this 

case is for self-weight of members drawn in previous steps.  

6. To distribute various loads on slab to beams, yield line pattern of loading is used. 

7. To define all members in model, replicate command is used. This command replicates all members. 

8. To assign support, select all the nodes at bottom most grid line either by clicking or by window Go to drop 

down menu Assign>Joint>Restraints>a dialogue box Joint Restraints will open>assign degrees of freedom>OK. 

9. Assign>Joint>Constraints >Diaphragm in box .Choose type of constraints>Add New Constraints. 

10. Define>Functions>Response Spectrum >a dialogue box Define Response Spectrum will open Choose 

Function Type to Add>Spectrum from File>Add New Function. 

11. Go to drop down menu Define>Analysis Cases> a dialogue box Analysis Cases will open. Click to Add new 

Case, Another dialogue box will open, as shown>Analysis Case Type>Response Spectrum. 

12. Define>Mass Source, A dialogue box will open, Define Mass source from LOADS. 

13. Analyze > Run Analysis. 

14. Click Run Now. 

15. After finishing the analysis, Display >Show Tables to display and print analysis results. 

16. Animations can also be obtained by clicking start animation button at the lower right corner. 

17. Display > Deformed shape to show the deformed shape of the structure. 

18. To view shear force and bending moments showShear/ Stresses toggle button is clicked. 

19. Shear or Moment radio button > OK. 

20. after successful Analysis of the structure, for concrete Design: Design> Concrete Frame Design> 

View/Revise Preferences. Select Design code as India (IS456- 2000)>OK. 

21. Design> Concrete Frame Design> Set Design Combo>check Automatically Generate Code-Based Design 

Load Combination> OK.  

22. Design> Concrete Frame Design> Start Design / Check of the structure.  

23. After competition of Design right Click on a member>Summary > to Display the Design Results as shown 

below. 

24. Click on Tabular Data to view Design Data in Tabular format. 
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V. Conclusions 
 In this thesis it is viewed that both SAP2000 and STAAD.Pro are efficient structural software. Both 

have helped revolutionize the system of analysis and design of structures. They have played a great role in 

eradicating the very tedious analysis and design procedure by hand, with very high precision as well. The 

purpose of this thesis is not to draw a general conclusion of which software is better than which, but a 

suggestion according to a predefined criteria as to when a user shall use either of the software. From the criteria 

set to evaluate the software a clear picture can be drawn for what purpose certain software shall be used. The 

main difference in the application of the software can be noticed from the past chapters as; SAP2000 doesn’t 

have a feature for designing continuum structural elements such as slabs, shells, and shear wall. The exclusion 

of such important feature in SAP2000 is probably a market strategy of CSI (producer of SAP2000) as to make 

users buy other CSI products which specialize in those areas such as SAFE. Through long years of experience 

on the market, both software packages have integrated user comments in order to polish the software 

functionality to a better precision and applicability. Thus precision of results for simpler structures is very 

similar in case of both software. 
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